Что такое Windows NET Framework

статьи

Довольно часто меня просят рассказать о Windows NET Framework и необходимости его установки. Впрочем, эта мысль, давно сидела у меня в голове, а посему речь в этой статье пойдет как раз об этом.

Windows NET Framework - иконка статьи

И так, собственно, к делу, благо вопросов об оном поступает, как я и сказал, Всё больше и больше.

Давайте приступим.

Общая информация о .NET

Windows NET Framework - это комплекс сетевых сервисов и приложений активно продвигаемый Microsoft. На сегодняшний день .NET стал для интернета тем же самым, чем сейчас является DirectX для игровой индустрии, а именно - общепризнанным стандартом. Чуть больше информации есть на Вики.

Устанавливать .NET надо всем в обязательно порядке - все больше и чаще сайтов и программ просто отказываются работать без этого пакета. В некотором смысле, это своеобразные кодеки для интернета и ряда программ :)

Windows NET Framework - логотип

С технической точки зрения одной из основных идей Windows NET Framework является совместимость различных служб, написанных на разных языках. Например, служба, написанная на C++ для Windows NET Framework, может обратиться к методу класса из библиотеки, написанной на Delphi; на C# можно написать класс, наследующий от класса, написанного на Visual Basic .NET, а исключение, созданное методом, написанным на C#, может быть перехвачено и обработано в Delphi.

Каждая библиотека (сборка) в .NET имеет сведения о своей версии, что позволяет устранить возможные конфликты между разными версиями сборок.

Где скачать и как установить Windows NET Framework

В общем, ставить не то чтобы в обязательном порядке для Windows всех семейств и расцветок, - и без него жить можно, но в какой-то момент Вы весьма вероятно наткнетесь на его нехватку и будет оное, думаю, не очень приятно.

А посему.. почему бы не поставить заранее? Вон, в Windows 7, например, Windows NET Framework уже включен в дистрибутив ОС и устанавливается во время установки системы автоматически.

Скачать можно, например, по этой ссылке. Версия по оной ровно 4.
Установка предельно проста и на ней я останавливаться не буду.
Никаких специфичных настроек не требуется.

несколько версий NET Framework в Windows

Заранее отвечая на частозадаваемый вопрос хочу сказать, что часто бывают нужны все версии, и 2-ая, и третья, и четвертая, и 4.5 и многие другие, если они в последствии будут выходить. Т.е удалять прошлый версии не надо, а вот устанавливать дополнительно, зачастую, необходимо.

Послесловие

Вот такие вот пироги. Надеюсь, что получилось более менее доходчиво и кому-то действительно пригодилось.

Если Вам есть что добавить или хотите что-то спросить, то пишите в комментариях или с помощью формы обратной связи. Всегда рад Вам и Вашим вопросам\комментариям.

сказать «спасибо»подписатьсяобучаться
Хотите знать и уметь, больше и сами?

Мы предлагаем Вам скачать бесплатные книги от автора. Компьютеры, программы, администрирование, сервера, сети и другое. Не является рекламой. Предложение от sonikelf.ru

Скачать книги
Sonikelf's Project's логотип Sonikelf's Project's логотип Космодамианская наб., 32-34 Россия, Москва (916) 174-8226
10000
87 Цепочка комментария
45 Ответы по цепочке
0 Последователи
 
Популярнейший комментарий
Цепочка актуального комментария
90 Авторы комментариев
  Подписаться  
Уведомление о
askold

а все ли версии устанавливаются одним махом?
1.0 и патч 1.1, 2.0, 3.0, 3.5 ?

vvm

Уважаемый Соник, пожалуйста, пишите что именно Вы предлагаете скачать с Вашего сайта. По первой ссылке - exe-файл размером 2.8 М, по-видимому он загружает сам пакет из инета. Т.е. на компьютер, который пока не подключен к инету, установить его не удастся. А второй имеет расширение avi. И никаких пояснений - то ли его надо переименовать в exe, msi, rar, а потом уже запускать. То ли это Ваша ошибка и Вы случайно дали ссылку на что-то другое.
Кстати, на сайте MS уже 4-я версия .NET.
Спасибо.

vvm

И все-таки.
Скачивается файл AVI, который после переименования в RAR открывается. Содержит 4-й .NET. По крайней мере инсталятор так называется. И буквы x64 в названии говорят о том, что версия для 64-разрядной Вин?
Ошибаюсь?

БопоХ

Как-то громко про фреймворк сказано, в линуксе без него превосходно можно обойтись, он там никаким местом не нужен и не встанет при большом желании. Для windows окружение в wine не в счет :)

Alexey

Не устанавливается почему-то. Запускаю инсталлятор и никаких десйтвий, отчего так?

Alexey

Windows 7, домашняя расширенная.

Wadim

Андрей ты настоящий ХАКЕР, если знаешь,
правильное значение этого слова.

wadim

извени забыл добавить
С уважением.

ЧесноГоворящий

спасибо. для меня, как для чайника, всё сразу стало понятно. спасибо за статью.

Lyusja

У меня на ХР изначально стоят 3 версии: 1.1 + 2.0 + 3.0. И до сих пор их всегда и на всё хватало.
Но на днях пыталась запустить Portable видеоконвертер XviD4PSP 6.0 Beta 2, но увы… получила сообщение: «Ошибка инициализации платформы .NET Framework» и разъяснение: «Для запуска этого приложения сначала необходимо установить одну из следующих версий .NET Framework: V4.0.30319».
Значит, версия 4 мне не подходит, надо чуть выше. Сначала разочарованная хотела пройти мимо… Но решила на всякий случай скачать Ваш архив и посмотреть, что же там внутри. И о!!! чудо!!!, там оказалась нужная мне версия и даже чуточку выше: V4.0.30319.1 (это высвечивает при наведении мышью на файл).
Надеюсь, от этого хуже не будет, ведь обычно пишут, что требуется .NET Framework НЕ НИЖЕ такой-то версии. Значит, выше можно… Как вы думаете, права ли я?
Спасибо!!! А я ведь наткнулась на Ваш сайт случайно… Словно провидение свыше привело меня сюда… Теперь буду иногда заглядывать… Есть полезные статьи по использованию нужных программ.

Dogom

Просто,доступно,спасибо. Буду советовать всем знакомым.

Gerain

а вот руссификатор (точнее языковой пакет RU) ставить обязательно? или его можно снести? а то он сам поставился

Nikonor

Спасибо!!! Очень пригодилось многое!!! Хотелось еще узнать про Visual C++, что это и для чего?

ZveroBoy

Хорошая статья, но непонятен источник .Net Framework 4. На сайте Microsoft подобного продукта просто нет... Хотелось бы получить комментарии от автора.

VERONIKA

Здравствуйте,Андрей!Спасибо за Вашу доброту!
У меня возникла проблема вот какого плана. ОС WINDOWS 7, ЛИЦЕНЗИОННАЯ, домашняя.Обновления происходили УСПЕШНО в течении года , а вот 10 февраля 2011 года прошел целый ряд обновлений, но обновление по поводу Microsoft .NET Framework 4 в 64-разрядных версиях получило отказ, и теперь каждый раз по ЗАВЕРШЕНИЮ РАБОТЫ происходит как бы остановка этого обновления и звершается ОТКАЗОМ. Код ошибки - 66A.
Если у меня ОС ЛИЦЕНЗИОННАЯ, нужно ли мне самой устанавливать Microsoft .NET Framework ?И ГДЕ ИСКАТЬ ПРИЧИНУ?
C большим уважением!Вероника.

proxy

Здравствуйте. Подскажите после установки Framework 4 можно удалить более ранние версии?

Dimarik

Здравствуйте! При установки(при нажатии кнопочки Download Latest) данного дополнения вылетает такое сообщение:
Необрабатываемое исключение в приложении.......
Невозможно загрузить файл или сборку "System.Core Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" или один из зависимых от них компонентов. Не удается найти укзанный файл.
В чем может быть проблема?
P.S. я думаю может версия CCleaner старая пользуюсь v.2.27.1070
За ранее спасибо! Спасибо Вам за работу ОЧЕНЬ полезный сайт, рекомендую всем своим знакомым;)

Kis-kis

Добрый день.Скачала программу, устанавливается только на диск С,
а там мало места, можно ли установить программу на диск D?

Michael

Каждые 5 минут предлагается установить обновления для .NET
При установке пишет:

Выполняется установка обновлений для платформы .NET версии 2.0 с пакетом обновления 2 (sp2) и 3.5. с пакетом обновления 1 (sp 1) в Windows server 2003 и Windows XP x 86 (kb2446704)

Просто зацикл. Перезагружал. Что надо делать?

lav46

Хочу сказать спасибо. Хоть разобралась что и для чего.

Straggler

Что-то у меня не получается - 2 дня пытаюсь установить: Скачал и установил Net Framework (48,1 Mb) по вашей ссылке . Но потом при установке qttabbar выходит сообщение "This application requires the .Net Framework version at least 3.5. Please instal .Net Framework then run this instaler again". Удалил и переустановил Net Framework с сайта microsoft по вашей ссылке - но безрезультатно.

Я, конечно, тот еще чайник, и скорее всего проблема в моих действиях или бездействиях.
Может быть проблема в установленном у меня на компе не лиценз. windows: ОС: Windows XP SP 3 версия 5.1. сборка 2600.xpsp_sp3_qfe. Или из-за антивирусников (NOD и AVG Antivirus) ?

Раньше, до того как случайно набрел на Ваш сайт и стал пользоваться Вашими статьями, я по малейшему случаю бежал к компьютерщикам за помощью, которая оказывалась или небесплатно или (и) после долгого ожидания. К тому же у нас в Ташкенте и спецов хороших найти не так то и легко. Но теперь, благодаря Вам, я пытаюсь во всем разобраться сам :) И следуя Вашим советам и рекомендациям сам слежу за своим ноутбуком, сына компом и нетбуком дочи :)
Большое спасибо за Ваш труд.

Gar5un

У меня проблема. Первый раз с такой встречаюсь. Я пробую установить .net framework 4.0 (мне нужен именно он!) . Версии 3.5 и ниже устанавливаются отлично без проблем. В 4 версии когда установка доходит до " установки клиентского профиля" ничего не происходит, а потом выкидывает окно: Установка не завершена.Причина: Элемент не найден. Я посмотрел в логах- ошибка 0×00000490 Гугл не знает как это вылечить.

Влад123

почти та же проблема что и Gar5un, не усатанвливает клиентский профиль, но пишет что не хватает одной или несольких трансакций.
Что делать?(((

panJurko.

Уважаемый Соник!
Моя проблема: сын установил мне 7 версию Виндовс, поставили Абби Файнридер, версия 9... При попытке открыть её выскакивает хорошо известное вам окно относительно необходимости установки v4.0.30319, Нашли, скачали (версия 48,1 мб), установили. Выскакивает, как и выскакивало, не хочет работать нормально. Помнится, Вы упоминали в одном из ответов, что v4.0.30319 устанавливается автоматически, при инсталляции Виндовс. Так чего оно капризничает? И что делать? Хочу обратить Ваше внимание: v4.0.30319 инсталлировали после установки Файнридера. С уважением, семидесятипятилетний чайник panJurko.

samm

@Sonikelf
Здравствуйте.
подскажите, можно ли удалять старые сервис паки framework? установил 3, в "установка - удаление программ" есть более старые версии.

Dina

При установке NET Framework4, появляется окно, которое сообщает, что произошла неисправимая ошибка. В файле журнала указано error code: (0x80070643) Как с этим бороться?

orsion1962

Спасибо что Вы думаете и за нас чайников. Мне понравилось написано всё очень доходчиво как раз для начинающих. Очень Вам признателен, ещё раз СПАСИБО!!!

Strima

Вот такая проблема при установке:
https://clip2net.com/404.html?url=%2Fs%2F1bHq0

nerwniy

уважаемый Sonikelf у меня проблема с загрузкой данного прилржения,.Есть возможность скачать прогу не через браузер?

nerwniy

вроде справился сам.
Спасибо за ваши советы.

игорь

Sonikelf спасибо за ссылку =) тока там и удалось поставить себе net framework 4 а то пол дня юзал по интернету - то антивир не пропускает то смс отправь а щас все норм и сайт в закладку этот надо бросить!!! спасибо еще раз!!! ;-)

Egor202

загрузили соника

всё ставится всё работает лично у меня кстати я тут узнал о 4 версии спасибо саиту и руководителям

Александр

От себя хочу заметить, что 4 .NET Framework стоит ставить только клиентский профиль (полный нужен только разработчикам ПО), в Windows 7 стоит 3.5.1 и кроме 4 версии ничего ставить не надо, в Vista и XP ставятся 3.5 SP1 и 4. Ссылка на версию 3.5 SP1 "https://www.microsoft.com/downloads/ru-ru/details.aspx?FamilyID=AB99342F-5D1A-413D-8319-81DA479AB0D7", на версию 4 "https://www.microsoft.com/downloads/ru-ru/details.aspx?familyid=0a391abd-25c1-4fc0-919f-b21f31ab88b7&displaylang=ru". Это автономные установщики.

Lёtchik

Здравствуйте. Есть идея создать образ с Windows XP и стандартным набором программ. Есть ли смысл ставить версии 1.0 ... 3.5 или просто установить версию 4.0? Её хватит для тех программ, которые во время установки просят поставить, например, 2.0 версию?

Vitok

Microsoft .NET Framework 4 почему-то сам устанавливается на диск D, а не на С?

POMOGITE

я скачал net.framework но когда нажимаю на instal ответ такой Leatrix Latency Fix is already installed on this computer

FLeShuk

Помогите ! При установке пишет "не удаётся найти указанный файл" в чём проблемма?

anklbens

Здравствуйте, при попытке открыть многии из моих игр и приложений выскакивает окно: необходимо установить одну из следующих версий .NET Framework v4.0.30319, установил. Выскакивает, как и выскакивало. У меня семерка . Прошу помочь в решении моей проблемы , заранее спасибо.

Олег

а старую версию сносить не надо?

CTAC

а можно устанавливать на не лицензионную XP

Владимир

Добрый день!
У меня тоже вопрос: можно ли устанавливать NET на нелицензионную версию WINDOWS ?

Skyrus

NET Framework 4(клиентская версия) прекрасно установился на абсолютно нелицензионную Win XP SP2. Перед запуском установки, правда, потребовал установить дополнительный пакет исправлений. Скачивал автономный установщик с оф. сайта. На компе, перед установкой, стоял только NET Framework 2.

LES[NIK]

Подскажите что мне делать с установкой .NET framework 4 когда устанавливается клиентский профиль вылезает окошко где написано что нет места на диске А (floppy) я нажимаю отмена а это окошко снова вылезает и никак его не убрать что мне делать?

Олег

Помогите пожалуйста - у меня в панели управления -> установка и удаление программ стоят 2.0 3.0 3.5 4.0 4.0 версии Framework.
Вопрос: можно ли удалить старые версии?

Руслан

Хочу спросить вот о чем, мой сын играет в игру Cross fire и он все время жалуется на то что у него очень большой пинг. Я специально нашёл ваш сайт и скачал программу, Leatrix Latency Fix.exe, но у меня вылазит что мне нужно установить microsoft .NET framework я скачал и он пишет то же самое (программу установил). Что делать ?

Юля

Здравствуйте. Подскажите пожалуйста. Я хочу установить программу Windows Life Writer. Загрузила установочный файл, а когда начинаю устанавливать эту программу, то в этом окошечке написано, что все уже установлено вместе с программой .Net framework. Но я не могу найти, где там это установлено. Может вообще удалить тогда .Net framework?

Альбина Мищенко

здравствуйте. У меня не которые обновления системы безопасности платформы микрософта.NET Fravework 2/.0 с пакетом обновления 2(SP2) в Windows Server 2003 и 32 разрядной версии WindowsXP(KB2686828)( обновление 1из4)...не удача!...............Windows XP(KB2656352)(обновление 2 из 4)...не удача!...................WindowsXP(KB2604092)(обновление 3из4).....не удача!................WindowsXP(KB2656369)(обновление 4из4)...не удача! я не знаю как бороться с этим? Помогите мне,пожалуйста! я же глухая! Думаю,что не справлюсь! С уважением Алла. Заранее спасибо!

Антон1

Здравствуйте. Мой вопрос, возможно, глуп, но меня, как "чайника", гложут сомнения... Дело в том, что я хочу сделать свой сервер для онлайн-игры, чтобы играть с друзьями. Во всех инструкциях по настройке и установке указано, что необходимо иметь .Net Framework версии 3.5. Но у меня уже стоит фреймворк более поздней версии, а в инструкциях по установке сервера о поздних версиях не сказано ни слова. Обязательно ли должна быть именно версия 3.5. или можно оставить свою? Есть ли между ними какая-то значительная разница?

aleks

Здравствуйте.У меня в обновлениях windows xp есть framework 2.0service pack 2 занимает 1.1гб.это много?и можно ли его удалить если есть следующие версии.Спасибо.

Рарара

При запуске некоторых приложений выскакивает - ошибка инициализации платформы .net framework 4.0.30319. Скачиваю с сайта Майкрософт самую последнию версию, и не чего не помогает. Win 7 Ultimate 62 битная. Помогите пожалуйста, уже месяца 2 вожусь с этой проблемой

зарегайся получиш 50 р
Лев

Здравствуйте Sonikelf.

А в службах NET Fravework запуск в ручную должен быть, или отключен? У меня Win.-7 sp 1

WWW.starspot.ru

ето лучше установить но не запускать при автозагрузке так как очень тормозит комп

Olik

Здравствуйте, у меня такая проблема установила игру для сына, а она не запускается, требует NET Fravework версии 3.5 Установила с сайта 4 версию, снова та же ошибка. Подскажите пожалуйста чайнику что делать. Заранее спасибо!

25KADR

Доброго времени суток, уважаемый пользователь!
Рады приветствовать Вас на страницах нашего проекта.
Попробуйте выполнить следующую последовательность действий:
1) Скачайте программу Revo Uninstaller, допустим по ссылке
2) Удалите ею пакет NET Framework 4.0. и все записи связанные с net framework, в частности (использовав пункт "расширенные" в программе)
3) Перезагрузите ПК
4) Установите требуемый NET Framework 3.5. (загрузив пакет с оф. сайта разработчиков), с учетом разрядности Вашей ОС (32 или 64 бита)
5) Запустите игру
Если результат тот же, приложите скрин ошибки или обратитесь на форум (sonikelf.ru/forum) там Вам всегда рады помочь, в любое время суток.
Успешного решения проблемы, обращайтесь, всега поможем.
p.s. Чайником быть не стыдно, чайником стыдно оставаться :-)

Слава

Здравствуйте! Подскажите что надо делать дальше???
Для работы программы необходимо наличие установленного .NET Framework 4.0, а также библиотек SQL Server CE 3.5 (для 32х битных ОС установить только 32x.msi, а для 64х битных – сначала 32x.msi, затем 64x.msi. Эти файлы находятся в архиве, в папке SQL Server CE 3.5).
Спасибо!!!

Слава

После установки .NET Framework 4.0, win и счет обновления после обновляется, обратно и счет обнову!!!
После удаление с пк .NET Framework 4.0 обновление не запаршивеет, но как запустить программу???
Спасибо!!!

Кама

Здравствуйте вчера я хотел загрузить игру а после загрузки мастер установки пишет что у меня уже данная версия у меня уже установлена и пишет что ошибка, помогите пож

Yancha

Здраствуйте! Помогите разобраться в ситуации, при попытке запуска он-лайн игры, при клике на ярлык, вылетает сообщение об ошибке, что для запуска данного приложения необходимо установить одну из версий net framework v4.0.30319 я скачал, установил, но опять тоже самое. Что это такое и как с этим бороться?

denis

когда я устанавливаю Microsoft .NET Framework 4 в середине загрузки выдает ошибку что в процессе установки произошла неисправимая ошибка что делать??? подскожите

Jastif

Здравствуйте всем, у меня вылазит ошибка . Посоветуйте, что мне нужно сделать, так как я мягко говоря, не хакер, то не знаю что это за проблема и как с ней бороться) Эта ошибка начала вылазить постоянно, когда я играл в игру mmorpg Aion. На всех серверах, где я играл небыло этой ошибки, а вот перешел на новый и столкнулся с ней на самых начальных этапах игры.

Crumbo

Мне необходимо установить NET.Framework 3.5.1 sp1 на моей Windows 7 32. Не знаю почему, но во "Включении и отключении компонентов Windows" он у меня не активирован. Я ставлю галочку (если честно, то там квадратик получается) напротив, жму OK. Начинается изменение функций, зеленая полоса почти доходит до конца, и тут вылетает окно с предупреждением: "Произошла ошибка. Некоторые компоненты установить не удалось" . Затем ОС предлагает перезагрузиться. Если отказаться от перезагрузки, то окно компонентов закрывается и при повторном заходе в него напротив NET.Framework 3.5 галочки нет. Если перезагрузиться и сделать то же самое - галочка тоже сбрасывается.

Ramzes

Вот кстати сайтик, в одном месте собраны ссылки на все версии .Net Framework. Может кому пригодится.
https://net-framework.ru/

Алексей Шелкунов

Спасибо!

Max

скачал и установил это приложение требует.net framework 3.5, запускаю игру(хон,ла2) все равно пишет это приложение требует.net framework 3.5 с пакетом обновления 1(( Винду сносить не хочу( подскажите плс что делать?

Юрок

Никогда не возникало проблем с установкой, но вот обновления с MS. После каждого обновления, которое занимает больше времени (на много) чем установка Windows и Fremework, "обнаруживаются" новые. И так кажется до бесконечности. Неужели нет возможности установить сразу одним файлом с последними обновлениями (ну что-то вроде интегрированных обновлений в винде)? И занимает места немеренно (почти 600 Мб).

Юрыч

Я сам поставил в новую систему пакет Microsoft.Net Framework v2+3+3.5, затем Microsoft.NET Framework 4. Нужен ли первый пакет или второй содержит всё необходимое?: С помощью UninstallTool (раздел: Системные) удалил первый пакет и почистил реестр. Вручную удалил оставшиеся папки. Но, как оказалось, в том же UninstallTool (в разделе Программы) остались пакет 2 (300 Мб.) и 3 (225 Мб.). Ну и 4 естественно. При попытке их удалить - они не удаляемые!!! Проверил систему на наличие и валидность пакетов с помощью NET Framework Setup Verification Tool - все в порядке! Кстати, размер диска уменьшился лишь на пару десятков Мб. Scanner.

Senbka

У меня семерка. Скачала Leatrix Latency Fix.exe и при установке пишет, что нужен .NET Fraemework.
Когда устанавливаю .NET Fraemework 4 пишет : Не выполнена установка .NET Fraemework 4; причина:
HRESULT 0xc8000247

Lida

Здраствуйте.NET Fraemework 4.5 питаюсь установить но вискакивает в начале установки окошко в котором пишет "уже выполняетса другой процес установки.Подождите немного ,а затем нажмите повторить...
но ту хоть вечность жди она все равно вибивает итак каждый раз...что мне с етим делать?

Lussole

У меня вдруг одновременно установились сразу несколько обновлений:
Microsoft .NET Framework 2.0 Servis Pack 2
Microsoft .NET Framework 3.0 Servis Pack 2
Microsoft .NET Framework 3.5 SP1
MSXML 6 Servis Pack 2 (KB973886)
Причем первые три занимают ну ОЧЕНЬ много места! Нужны ли первые два - .NET. Framework 2.0 Servis Pack 2 и .NET. Framework 3.0 Servis Pack 2, если потом стоит ещё и .NET. Framework 3.5 SP1?

василий

MICROSOFT присылает столько загрузок, что и места на компе не остаётся. Не могу определить, что и сколько загружать? ПОМОГИТЕ ДЕДУ 78-и лет!

Светлана

А у меня среди установленных уже есть
Microsoft .NET Framework 2.0 Servis Pack 2
Microsoft .NET Framework 3.0 Servis Pack 2
Microsoft .NET Framework 3.5 SP1

ЧТО ОСТАВЛЯТЬ??? И надо ли устанавливать версию 4?

Игорь

Бред!!! Купил ноут год назад снёс к чертям его и всё работает отлично!

Данил

Спасибо за статью

Екатерина

Здравствуйте всем, при установке программы в конце пишет "установка не завершена" и выдает ошибку: HRESULT 0xc8000222. Посоветуйте, что мне нужно сделать.а когда устанавливаем антивирус Касперского, выдает "невозможна установка Microsoft.net!

andrew87

А на нелицензионный виндовс можно ставить?

Гость

для игры нужен установленный microsoft net framework2.0 питаюсь его установить,грузится и в конце пишет:Для установки или настройки необходимо использовать параметр Включение и отключение параметров виндовс в панели управления.

Илья

Здравствуйте. У меня ССleaner показывает, что net framework весит 70 ГБ - это нормвльно?

masha777

сколько памяти нужно? 256 хватит?

Абдулла

не устанавливается версия 1.1 а он мне необходим , подскажите пожалуста.

Абдулла

выводится сообщение что установка завершена преждевременно, при повторении этой ошибки обратитесь к изготовителю. Чистил framework cleaner tools не помогло

николай

тишет что установка не может завершиться успешно

Nick

Такая вот проблема я использую исзевстный лаунчер STEAM много времени и всё работало прекрасно но в один прекрасный день мне выдало ошибку якобы не достатка программы которую вы описывали что это может быть могла ли она как либо удолится или это баги

Матвей

Если у вас не было Net. Framework то просто зайдите туда где программы удаляют, точно не могу сказать с телефона пишу, там с лева будут надписи и вот там нужно будет нажать на одну из них и откроется минюшка с программами, там нужно отметить Net. Framework и нажать ок и он сам установится, можите подсказать будут ли какие нибудь проблемы ? Если я свои программы установил и не знал как устоновить net. Framework потому что скачивая ее с инета ошибку в конце выдавала, просто я кучу приложений запускал без .

Руслан

Не могли бы вы подсказать, почему на винде 10х86 не могу установить никакой framework?ни 3.5, ни 4.0, ни 4.5? очень долго идет загрузка, и в последний момент она обрывается

Николай

Большое Вам Спасибо,все просто и доходчиво,дай вам бог долгих лет

xverkax

Даже не осознавая функционал NET Framework - программу необходимо скачать и установить на компьютер. Приложение способствует работе других программ и является целым комплексом сервисов, доступных бесплатно.
Бесплатно скачать и установить NET Framework для полноценной работы компьютера можно на сайте https://net-framework-download.ru